我正在将Angular从8升级到11。我的项目中的所有软件包都与Angular 11兼容,除了ng2-select2,所以我用npm上的另一个包装替换了它,即wisewise-ng2-select2,但看起来它仅兼容Angular 9不适用于更高版本。他们只是在Angular构建中给出错误。

Error: Unexpected value 'Select2Module in node_modules/tastewise-ng2-select2/dist/ng2-select2.d.ts' imported by the module 'Module in module.ts'. Please add a @NgModule annotation.

谁能建议一个可用的插件,而无需进行额外的代码更改?提前致谢。

你可以使用ng-select替代之前的ng2-select。